Azure AD Users May Be Unable to Authenticate to Frame or Receive New Persistent Desktop / User Volume
May 12, 08:15 UTCMay 12, 08:15 UTC
Duration
0m
Impact
Minor
Root cause
Not disclosed
Nutanix, 90 days
0 incidents
Affected
Not listed by the vendor.
Final update
An update to a backend SAML2 library resulted in XML Namespaces being improperly stripped from Azure AD SAML2 claims. This resulted in some users being unable to authenticate as Frame was unable to properly match these claims in order to establish user identify. Users who were able to authenticate may have improperly received a new Persistent Desktop and/or User Volume (Enterprise Profile or Personal Drive) upon starting a session. This issue seems to only affect customers on our Frame Commercial Platform using Azure AD via SAML2 integration with Frame. This issue was first reported at 1:15AM PDT and was resolved by 5:15AM PDT on Thursday, May 12, 2022.
Timeline
- Resolved · May 12, 08:15 UTC
An update to a backend SAML2 library resulted in XML Namespaces being improperly stripped from Azure AD SAML2 claims. This resulted in some users being unable to authenticate as Frame was unable to properly match these claims in order to establish user identify. Users who were able to authenticate may have improperly received a new Persistent Desktop and/or User Volume (Enterprise Profile or Personal Drive) upon starting a session. This issue seems to only affect customers on our Frame Commercial Platform using Azure AD via SAML2 integration with Frame. This issue was first reported at 1:15AM PDT and was resolved by 5:15AM PDT on Thursday, May 12, 2022.
More from Nutanix
Full historyNutanix MCM Intermittent Availabilitylasted 0mOutagelasted 1h 20mIntermittent issues with logging into the Frame consolelasted 48mIntermittent Issues Accessing Frame Consolelasted 1h 17mUsers are unable to start sessions when using older versions of Frame Enterprise Profile Driverlasted 10h 55mIntermittent issues with Frame serviceslasted 17m