Skip to content
Convex · Data and observabilityApr 9, 2026, 05:42 UTC 5 months ago

Small percentage of deployments experiencing outage

MajorDatabaseUpdated 2h ago
Apr 9, 05:42 UTCApr 9, 06:24 UTC
Duration
43m
Impact
Major
Root cause
Database
Convex, 90 days
6 incidents
Affected
Free & StarterProfessionalBusinessLive Traffic - Free & StarterLive Traffic - ProfessionalLive Traffic - BusinessDevelopment Services - Free & StarterDevelopment Services - ProfessionalDevelopment Services - Business
Status page

Final update

This issue is considered resolved. Impact: A small percentage of Convex deployments experienced sporadic availability for approximately 17 minutes, from 22:42 to 22:59 PM PT. Root cause: one of our database clusters experienced a routine primary failover event. During the primary promotion process, the orchestration system failed to provision a replica that was ready to accept new database writes. Out of an abundance of caution, Convex will only use database clusters that support semi-sync replication, where at least two machines persist the writes before considering the write successful. Since the replicas were not ready, this cluster was not usable by Convex. Human operators were paged to intervene and fix the broken automation. We're working with our database partners to better understand what went wrong and what changes will prevent it in the future.

Timeline

  1. Resolved · Apr 9, 06:24 UTC
    This issue is considered resolved. Impact: A small percentage of Convex deployments experienced sporadic availability for approximately 17 minutes, from 22:42 to 22:59 PM PT. Root cause: one of our database clusters experienced a routine primary failover event. During the primary promotion process, the orchestration system failed to provision a replica that was ready to accept new database writes. Out of an abundance of caution, Convex will only use database clusters that support semi-sync replication, where at least two machines persist the writes before considering the write successful. Since the replicas were not ready, this cluster was not usable by Convex. Human operators were paged to intervene and fix the broken automation. We're working with our database partners to better understand what went wrong and what changes will prevent it in the future.
  2. Monitoring · Apr 9, 05:59 UTC
    A fix has been implemented and we are monitoring the results.
  3. Investigating · Apr 9, 05:42 UTC
    Seems related to a problematic database failover. Updates soon.

More from Convex

Full history
StartedIncidentDuration
Sep 2821:09 UTC5 days agoAI gateway unavailable1h 4m
Sep 1823:01 UTC2 weeks agoDashboard logins degraded1h 7m
Aug 1623:33 UTC6 weeks agoAccount verification/team invite emails not working1h 53m
Aug 1203:41 UTC7 weeks agoSome HTTP Actions returning 40420m
Aug 501:42 UTC8 weeks agoAction failures for business deployments that use createFunctionHandle15m
Jul 1505:35 UTC2 months agoNew deployments unable to push Node Actions to Convex57m

Also caused by database

All
StartedIncidentDuration
Sep 2310:11 UTC10 days agoIncident across several servicesGitHub18h 44m
Sep 1309:16 UTC2 weeks agoIncident with several GitHub ServicesGitHub1h 29m
Sep 921:53 UTC3 weeks agoINC20000211Snowflake1h 58m
Aug 2616:17 UTC5 weeks agoIssues performance is degraded in the USSentry4h 19m
Aug 1216:16 UTC7 weeks agoIncident with Pull Requests and IssuesGitHub25m
Aug 818:57 UTC8 weeks agoAccount Registration, Droplets, and Related ServicesDigitalOcean6h 3m

Outages by email

Saturday mornings: the week's major outages, new postmortems and disclosed breaches, only in weeks that had some.

Double opt-in. Unsubscribe any time.